< ComCon - Course - RPG IV and ILE Advanced
  ComCon
Contact
    HOME  |  ABOUT US  |  COMMUNITY  |  DOWNLOAD
 
October 17-19, 2017 in Minneapolis        


    Services
    Courses
    Workshops
    Sessions
    Articles
    Books

RPG IV and ILE Advanced

Duration

2 days

What the Course Covers

This course will teach the participants advanced topics for experienced RPG IV ILE programmers. There are extensive hands-on exercises.

How Can You Apply the Skills You Will Learn?

On completion of the course, participants should be able to code and use the advanced features.

Who Should Attend

Experienced RPG IV ILE programmers.

Prerequisites

Before taking this course, a student should:
  • Have at least six months experience of programming in RPG IV
  • A knowledge of the modern development environment (RSE/WDSC/Rdi) would be advantageous
    available through RSE/WDSC/Rdi for Programmers

Agenda

The following topics will be covered
  • ILE Revisited
    • ILE Review
    • Maintaing Binder Language
    • Using Activation Groups
  • Triggers and Referential Integrity
  • N-Tier Design in RPG IV
  • Pointers and User Spaces
  • Externalizing I/O
Home | About Us | System i Community | Contact
ComCon © 1994 - 2017. This site is hosted on an  i